Install Linknx


apt-get install build-essential bin86 libesmtp5 libesmtp-dev libcppunit-dev libcurl4-openssl-dev


all packages for Debian sarge (i386 and amd64) or newer. To use them with apt, add

to /etc/apt/sources.list and run

apt-get update

. Note, that they can be older than the released sources.

The repository is signed with the following key (can be added with apt-key):

-----BEGIN PGP PUBLIC KEY BLOCK-----
Version: GnuPG v1.4.6 (GNU/Linux)
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=ztcU
-----END PGP PUBLIC KEY BLOCK-----

To add it, paste the public-key block into a file and add it with "apt-key add <file-name>".


apt-get install pthsem-dev


Install log4cpp and lua5.1 through Software Management
Download linknx from http://sourceforge.net/projects/linknx/
Copy it into your home directory and set the rights to 777
tar -xzf linknx -0.0.1.26.tar.gz

cd linknx -0.0.1.25

chmod 777 -R *

./configure


make


make install


make check


ln -s /usr/local/share/doc/linknx /var/lib/linknx


ln /var/lib/linknx


Erstellen des persist Ordners


mkdir /var/linknx/persist


I moved the config .xml to following folder.

/var/linknx/linknx.xml


Start linknx with


linknx –config=/var/linknx/linknx.xml

For a start at boot add in


/etc/rc.local

following lines


echo Starte LINKNX
PATH=/usr/local/bin/
linknx –-config=/var/linknx/linknx.xml